ERROR nach Installation

Diskussionen zu dem Werkzeug hinter der Karte und für eigene Garminkarten
Antworten
Gast

ERROR nach Installation

Beitrag von Gast » Fr Jan 11, 2019 10:02 pm

[lutz schrieb am 10.03.14 11:20]
Hallo,

nachdem ich unter Linux gemäß Anleitung den MapComposer installiert habe,
wollte ich die Beispielkarte generieren und erhielt hierbei im Logfile in rot
folgenden Hinweis:

[color=]java.io.IOException: Cannot run program "reg" (in directory
"/home/lutz/GPS/OSM_Composer/data"): error=2, Datei oder Verzeichnis nicht
gefunden

Was hab´ ich falsch gemacht?
Für Hilfe wäre ich sehr dankbar - Lutz
Gast

Re: ERROR nach Installation

Beitrag von Gast » Fr Jan 11, 2019 10:02 pm

[Nop schrieb am 10.03.14 13:05]
Reg ist ein Windows-Programm, das zur Anmeldung der Karte in der
Windows-Registry benutzt wird. Beides gibt es natürlich unter Linux nicht.

Abhilfe: Häkchen bei "Karte in Mapsource installieren" entfernen.

bye, Nop
Gast

Re: ERROR nach Installation

Beitrag von Gast » Fr Jan 11, 2019 10:02 pm

[lutz schrieb am 10.03.14 13:52]
Hallo,

danke für die schnelle Antwort - leider hat´s noch nicht geklappt - vielleicht
mach ich noch was falsch:

Beispielkarte markieren / rechte Maustaste Bearbeiten / Aktion - MapSource
Integration - Häkchen entfernen

erzeugt beim anschließenden Generieren einen identischen Fehlerkommentar!

freundlichen Gruß Lutz
Gast

Re: ERROR nach Installation

Beitrag von Gast » Fr Jan 11, 2019 10:02 pm

[lutz schrieb am 10.03.14 14:17]
Hallo,

Nachtrag zu meinem vorherigen :

in OSM_Composer/data sind 3 *.osm Dateien, die leer sind, angelegt worden -
und die Datei commands.log zeigt:

reg delete
"HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Garmin\MapSource\Families\MC_Beispiel"
/f

Gruß Lutz
Gast

Re: ERROR nach Installation

Beitrag von Gast » Fr Jan 11, 2019 10:02 pm

[Nop schrieb am 10.03.14 18:50]
Sollte er eigenltich ohne das Häkchen nicht mehr machen.

Es gibt noch einen Workaround: Leg im Suchpfad ein Script namens "reg" an, daß
nichts tut. Dann müßte er auch glücklich sein.

bye, Nop
Gast

Re: ERROR nach Installation

Beitrag von Gast » Fr Jan 11, 2019 10:02 pm

[lutz schrieb am 10.03.14 19:50]
Hallo,

ich muss noch mal nachbohren:

der Fehler bleibt - leider.

Ich hab´ im Suchpad [/home/lutz/GPS/OSM_Composer/data] ein Skript reg angelegt:

-rwxrwxrwx 1 lutz lutz 25 Mär 10 19:27 reg

mit

#! /bin/bash
# nichts tun

Gibt es noch eine Idee?

Danke und freundlichen Gruß Lutz
Antworten